Safari - Buchstaben / Zahlendarstellung

Seit einem update des bestehenden Betriebsystems El Capitan von ca. 7 Woche, habe ich mit Safari Probleme in der Textdarstellung bei unterschiedlichen Seitenaufrufen - nicht bei allen!. Diese waren zuvor nicht da. Die Fehldarstellungen sind überwiegend bei Buchstaben und Zahlen, welche so zusammengeschoben werden, dass man diese nicht mehr lesen kann. So z.B. bei ebay, wo ich teilweise nur noch 'Buchstaben/Zahlen-Salat' sehe. Mit Opera/ Firefox gibt es keine Darstellungsprobleme, allerdings arbeite ich mit diesen nicht so gerne.

Ich habe es schon mit unterschiedlichen Einstellungen in den Voreinstellungen in Safari selbst probiert (Standartcodierung), doch diese waren nicht erfolgreich. Derzeit ist Mitteleuropäisch (MaxOs) eingestellt. Die Fehldarstellung tritt immer auf und ist nicht irgendwie bedingt z.B. wenn auch andere Programme geöffnet sind. Ob Cookies mit oder nicht eingestellt ist, spielt ebenfalls keine Rolle. Schriften wurden auch nicht entfernt oder verändert.

imac 27 zoll
OS X El Capitan Version 10.11.6
Safari 10.1.2

Kann mir da jemand weiterhelfen?
Ich möchte mit El Capitan weiterarbeiten und nicht auf eine neue Betriebssoftware aufrüsten.
Falls möglich, würde ich gerne die alte Safari-Version zurück haben wollen - falls das gehen sollte.

Oder geht es irgendwie mit dem Löschen einer Präferenz/Voreinstellung?

Danke für die Hilfestellung.

Sepp

Safari komplett zurücksetzen

In den Einstellungen unter Sicherheit/Datenschutz sämtliche Websitedaten löschen.

Entwickler-Menü anschalten und Caches löschen. Verlauf löschen. Danach Safari neustarten.

Eine ältere Safari-Version bekommst du nur über ein Backup.

Tipps leider ohne Wirkung

Safari komplett zurücksetzen
GIBT ES DA NOCH WAS ANDERES ALS DAS, WAS DU VORGESCHLAGEN HAST?
DAS HABE ICH ALLES DURCHGEFÜHRT

Entwickler-Menü anschalten und Caches löschen.
AUSGEFÜHRT

Verlauf löschen
MACHE ICH GRUNDSÄTZLICH NACH JEDER SITZUNG

Danach Safari neustarten.
AUSGEFÜHRT

LEIDER HAT DAS ALLES NICHTS GEHOLFEN.

sepp

Safari-Einstellungen löschen

com.apple.Safari.plist, liegt in Home/Library/Preferences.

Möglicherweise ist diese Datei defekt. Besser noch: Die Datei auf den Desktop bewegen (vorher Safari schließen), Safari neu starten. Liegt es nicht daran, die Datei wieder zurück ins Verzeichnis schieben.

leider kann ich selbst über

die Suchfunktion/Lupe die Datei
com.apple.Safari.plist,
nicht finden.

Auch wenn ich einen alten Safari-Version auf dem Rechner öffne und auf die fraglichen Seiten gehe, zeigt er mir den 'Buchstabensalat' an. Es scheint aus so, dass diese alle Voreinstellungen z.B. Favoriten aus dem neuerem Safari übernimmt bzw. auf den gleichen Ordner/Ablage zugreift.

'Erste Hilfe' brachte auch nichts.

sepp

Library

Den Library Ordner kannst du aufrufen, indem du mit gedrückter Shift-Taste ins "Gehe zu" Menü des Finders klickst.

alt Taste

Es ist die "alt"-Taste, welche den Library Ordner mit anzeigt.

Gruß
P.

Bei mir Shift

macOS 10.12.6.

Nur bei Drücken von Shift wird "Library" im Menü angezeigt.

Nutzt du noch eine ältere Version?

Die Library war schon immer...

über /Gehe zu und dann bei gedrückter Alt (Option)-Taste angezeigt und anklickbar (schiebt sich dann zwischen Benutzerordner und Computer)

Bei mir gab's mal Störungen in der Schriftdarstellung in Safari, nachdem ich versucht hatte über /cmd, und /Erweitert (Zahnrad) bei den /Bedienungshilfen den Haken beim ersten Kästchen zu setzen und einen größeren Schriftgrad einzustellen (Standard ist 9 und 1. Kästchen NICHT angehakt). 1. Kästchen: Keine Schriftgrößen verwenden, die kleiner sind als...

In der Library heißen die Safari.plist-Dateien auch anders: SafariExtensionCompanion_125... oder kürzer: Sarfari_nummernfolge - Löschversuch NUR nach deren Kopie zur Sicherung für Rück-Einfügen ;-)
Es gibt noch einen com.apple.scripteditor.id.nummernfolge.sfl, dessen Funktion ich nicht kenne...

-------------------
von-Windows über 15 Jahre ermüdet... ;-) seit 2010: 4xAir-13",4xiMac 27"-MBP 15"-MacPro-5xiMac 21"-iPhones+iPads

Wow!

Hannes schrieb:
macOS 10.12.6.

Nur bei Drücken von Shift wird "Library" im Menü angezeigt.

Nutzt du noch eine ältere Version?

Welche Tastatur verwendest du? Habe ich noch nie gehört oder gesehen.

in keinem OS

Liebe Leute! :-)

Ich hab das jetzt auf zwei Macs (Desktop, MacBook) ausprobiert, jeweils macOS Sierra mit allen Updates:

Nur der Klick mit gedrückter Umschalttaste (Shift) ins Menü "Gehe zu" zeigt den Eintrag "Library" an.

Beim Drücken von ALT tut sich nichts!

Das kann doch nicht nur bei mir so sein...?!?!

Njet

Unter OS 10.10 und 10.11 ist es die Alt-Taste, zumindest bei meinen Rechnern. Mit Shift passiert nichts. Offenbar hat Apple das geändert, warum auch immer.

Library Ordner permanent anzeigen

Man kann sich den Library Ordner auch permanent anzeigen lassen. Hierzu öffnet man im Finder seinen Home- bzw. Benutzerordner, wählt dann oben in der Menüleiste Darstellung/Darstellungsoptionen einblenden und setzt dort den Haken bei Ordner Library anzeigen.

Wahrscheinlich...

Hannes schrieb:
Ich hab das jetzt auf zwei Macs (Desktop, MacBook) ausprobiert, jeweils macOS Sierra mit allen Updates:

Nur der Klick mit gedrückter Umschalttaste (Shift) ins Menü "Gehe zu" zeigt den Eintrag "Library" an.

Beim Drücken von ALT tut sich nichts!

Das kann doch nicht nur bei mir so sein...?!?!

... schon - anscheinend ist bei Dir über /Tastatur in den /Einstellungen ein Kurzbefehl aktiviert/eingerichtet, der NICHT Standard ist - anders kann ich es mir nicht erklären, denn ich kenne diese Funktion seit LION und über alle Versionen NUR über die ALT-Taste ;-) :)

Wenn Du dann den Mac/MB über dieselbe Migration (Time Machine oder so) aufgebaut hast, erklärt sich, warum diese Abweichung auf Deinen BEIDEN Systemen zu finden ist.

Vielleicht wirst Du fündig... (schlimm ist es ja nicht)
-------------------
von-Windows über 15 Jahre ermüdet... ;-) seit 2010: 4xAir-13",4xiMac 27"-MBP 15"-MacPro-5xiMac 21"-iPhones+iPads

Beides ist richtig!

Wenn man/frau die permanente Anzeige wie von @macman beschrieben aktiviert hat, dann läuft es mit der shift-Taste.
Wenn nicht die permanente Anzeige aktiviert ist, dann die alt-Taste.
Kleines Häckchen, große Wirkung.

Das ist es!

linne schrieb:
Wenn man/frau die permanente Anzeige wie von @macman beschrieben aktiviert hat, dann läuft es mit der shift-Taste.
Wenn nicht die permanente Anzeige aktiviert ist, dann die alt-Taste.
Kleines Häckchen, große Wirkung.

Dickes Dankeschön an Euch beide!

Ich hatte schon zwischenzeitlich an meinem Verstand gezweifelt, weil ich an der Sondertasten-Konfiguration nichts geändert hatte.

Es stimmt: Ich hatte in den Finder-Darstellungsoptionen für das Home-Verzeichnis auf beiden Systemen den Haken bei "Ordner Library anzeigen" gesetzt (Ordner wird in der Verzeichnisstruktur sichtbar). In diesem Setting wird "Library" im Menü "Gehe zu" nur mit gedrückter Shift-Taste angezeigt.

Nehme ich den Haken in den Einstellungen weg, wird "Library im Menü "Gehe zu" mit gedrückter Alt-Taste (und nicht mit Shift) sichtbar.

Über den Sinn und Unsinn dieses Systemverhaltens muss ich wohl nichts sagen...

Na auf jeden Fall: Problem gelöst! :)