High Sierra: Löschen extrem langsam

04. März 2019 11:42 Uhr - ujoss

Löschen großer (15GB, 25GB) Dateien geht extrem langsam. Und es gibt keinen Fortschrittsbalken mehr nach dem Leeren des Papierkorbs. Liegt das an High Sierra oder an meinem 5kiMac? 

Ich habe den Papierkorb geleert. Aber ich habe 20 Minuten später immer noch nicht mehr Speicherplatz.

Danke im Voraus Ulli

 

Modellname: iMac

  Modell-Identifizierung: iMac17,1

  Prozessortyp: Intel Core i7

  Prozessorgeschwindigkeit: 4 GHz

  Anzahl der Prozessoren: 1

  Gesamtanzahl der Kerne: 4

  L2-Cache (pro Kern): 256 KB

  L3-Cache: 8 MB

  Speicher: 32 GB

Das ist ein sehr unübliches Verhalten. Wobei das Löschen derart großer Dateien natürlich bei einer lahmen Festplatte sehr viel länger dauert als bei einer modernen SSD.

HFS oder APFS?

SSD, richtig, keine Fusion... Dasselbe ist mir mit meinem 2011er MBP passiert. Da habe ich es noch auf das Alter geschoben, dort habe ich allerdings auch eine SSD drin.

Jetzt 15.56 ist der Papierkorb übrigens immer noch nicht geleert.

Es gibt 2 Möglichkeiten, den Papierkorb zu löschen. Ich glaube, das wird im Finder > Einstellungen gewählt. Sitze gerade ohne Mac hier, sorry. Die „gründliche“ kann dazu führen, dass es ewig dauert, hatte ich auch mal versucht. Dabei werden, soweit ich mich erinnere nicht nur der Eintrag im Inhaltsverzeichnis, sondern auch die Daten auf der Platte genullt. Das dauert dann.

 

Es gibt 2 Möglichkeiten, den Papierkorb zu löschen. Ich glaube, das wird im Finder > Einstellungen gewählt. Sitze gerade ohne Mac hier, sorry. Die „gründliche“ kann dazu führen, dass es ewig dauert, hatte ich auch mal versucht. Dabei werden, soweit ich mich erinnere nicht nur der Eintrag im Inhaltsverzeichnis, sondern auch die Daten auf der Platte genullt. Das dauert dann.

Schon länger nicht mehr. Grund: Auf SSDs ist das Überschreiben nicht nötig, sogar schädlich. Daher wurde die Option "Sicheres Löschen" entfernt, weil das nur für Festplatten Sinn ergeben hat. SSDs sind gänzlich anders aufgebaut. 

Das geht bei einer SSD normalerweise recht fix.

Ich tippe da auf ein Systemproblem. Mal die üblichen Kniffe anwenden, würde ich sagen...

Das ging auf meinem alten 2011er MBP mit SSD auch schnell, bis ich auf High Sierra upgedated habe. 

Kann es daran liegen, dass ich dabei auch Ordner mit dem gesamten Inhalt gelöscht habe. Früher bei Windows musste man erst den Inhalt und dann konnte man den Ordner löschen. Aber man wurde gewarnt, weil man ihn nicht löschen konnte. :-(

Übliche Kniffe, wie Festplattendienstprogramm und pram?

Danke

Könnte an der Datensicherung liegen. Hast du die mal neu auf einem externem Medium gemacht? Bei wurde die SSD plötzlich als komplett voll angezeigt, owohl ca. 50% frei gewesens ein müssen. Das änderte sich auch nicht, nachdem ich mehrere zig GB gelöscht hatte. Nach Anschluss der TimeMachine-Platte und DAtensicherung extern war es wieder okay.

Da wurde eine Datensicherung im Hintergrund auf der SSD abgelegt. Wie kann man diesen Unfug eigentlich verhindern?

Scheint mir bei mir eher unwahrscheinlich. Auf meinem MBP habe ich (ähem) überhaupt keine automatisierte Datensicherung. Auf dem iMac läuft alles seit Jahren extern. Also zwei unterschiedliche Konfigurationen. Und wie gesagt, diese Probleme habe ich erst seit High Sierra. :-((

Was bekommst Du als Ergebnis nach Eingabe von 

tmutil listlocalsnapshots /

im Terminal?

 

Früher ging die Deaktivierung über das Terminal (in High Sierra wohl nicht mehr?)

sudo tmutil disablelocal

=> löscht(e) lokale Backups und deaktiviert(e) Anlage lokaler Backups (die nach Abschluss eines TM-Backups auf eine externe HD gelöscht werden (sollten))

sudo tmutil enablelocal

=> aktiviert(e) den Prozess wieder

Man muss nun 

tmutil thinlocalsnapshots

verwenden, siehe zB hier

https://apple.stackexchange.com/questions/309143/how-to-thin-your-local…

 

Gruß