macOS Mojave auf nicht unterstützer Hardware: Update auf Version 10.14.4 ohne Probleme

28. März 2019 15:00 Uhr - Redaktion

Über die Möglichkeit, macOS Mojave auf nicht unterstützter Hardware zu installieren, haben wir in den vergangenen Monaten mehrfach berichtet. Offiziell läuft das neue Betriebssystem auf Macs ab Baujahr 2012 (bzw. Mac Pro ab 2010), mit einem Patcher kann auch älteren Rechnern neues Leben eingehaucht werden (ab Baureihe 2008/2009). Nun gibt es eine neue Version (1.3) des Patchers, die Unterstützung für das vor kurzem veröffentlichte Betriebssystemupdate macOS 10.14.4 bietet.

Wir konnten damit ein MacBook Pro aus dem Jahr 2010 erfolgreich auf macOS 10.14.4 aktualisieren. Ganz wichtig ist jedoch, dass dabei NICHT die Softwareaktualisierung von macOS genutzt wird, sondern die folgende Updateanleitung beachtet wird:

 
macOS Mojave auf MacBook Pro Baujahr 2010
 
Läuft problemlos: macOS 10.14.4 auf einem MacBook Pro des Baujahrs 2010.

 

1) Version 1.3 des Patchers herunterladen.
2) Damit den kompletten macOS-10.14.4-Installer herunterladen.
3) Auf Basis dieses Installers mit dem Patcher einen neuen Installer-USB-Stick (acht GB oder größer) erstellen.
4) Von diesem Installer-Stick booten (nach dem Einschalten Alt-Taste gedrückt halten, um in den Bootmanager zu kommen).
5) Nun macOS 10.14.4 installieren (eine vorhandene Installation wird aktualisiert, unter Beibehaltung der Daten). FileVault-Startvolumes müssen vorher per Festplattendienstprogramm entsperrt werden.
6) Nach Abschluss der Installation erneut vom Installer-Stick booten und die Post-Patches installieren.
7) Die Option "Force Cache Rebuild" aktivieren und von regulärem Startvolume neustarten.
8) Jetzt noch den Patcher Updater (siehe Dienstprogramme-Ordner) starten und die verfügbaren Patches herunterladen.

Wer kritische Daten auf dem Gerät hat, sollte vor der Aktualisierung sicherheitshalber ein vollständiges Backup anlegen.

Und ganz grundsätzlich: Die gesamte Prozedur (Installation von Mojave auf offiziell nicht unterstützter Hardware) ist nur experimentierfreudigen, technisch versierten Anwendern, die der englischen Sprache mächtig sind, zu empfehlen. Die Nutzung des "macOS Mojave Patcher Tool" erfolgt auf eigene Gefahr, es gibt keinerlei Support durch Apple!

 

 

Der Entwickler des Patchers hat auf seiner Web-Seite eine bebilderte Schritt-für-Schritt-Anleitung bereitgestellt, zudem gibt es ein Video-Tutorial (eingebettet in diesen Artikel). Mit dem "macOS Mojave Patcher Tool" lässt sich das neue Betriebssystem auf folgenden Rechnern, die von Apple nicht mehr unterstützt werden, installieren:

• Xserve ab Baureihe 2008.
• Mac Pro ab Baureihe 2008.
• iMac der Baureihen "Anfang 2008" bis "Ende 2011".
• MacBook Air der Baureihen "Ende 2008" bis "Mitte 2011".
• MacBook Pro der Baureihen "Anfang 2008" bis "Ende 2011".
• Mac mini der Baureihen "Anfang 2009" und "Mitte 2011".
• MacBook der Baureihen "Anfang 2009" bis "Mitte 2010".
• Aluminium-MacBook der Baureihe "Ende 2008".

Die neue Version 1.3 des Patchers löst einige bisher bestehende Probleme, zum Beispiel nicht funktionierendes WLAN oder fehlende Grafikbeschleunigung auf bestimmten Systemen ("Fixed an issue with graphics acceleration on non-Metal GPUs. Added support for previously unsupported Broadcom BCM4321 WiFi modules").

Kommentare

Vorab: Ich kann völlig verstehen, dass Apple nach 10 Jahren die Update-Versorgung für Rechner beendet - das ist ein Jahrzehnt!

Dennoch ist es super, dass man die alten Rechner, die meist noch gut funktionieren, via Patch noch mit aktuellem OS weiterbetreiben kann. Verwendungszwecke gibt es genug, und sei es nur fürs Gästezimmer als Bedarfs-Notebook...